Loading...

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

When you install Adobe PDF Library on a macOS Catalina platform (v10.15 or later), when using Xcode v12 or v11, you may see an error when running sample programs. If you are working with a command line tool, the message will appear as text:

.../DL180Flattener.ppi/DL180Flattener) not valid for use in process using Library Validation: library load disallowed by system policy

.../DL180PDFProcessor.ppi/DL180PDFProcessor) not valid for use in process using Library Validation: library load disallowed by system policy

If you are working with the Xcode development environment for macOS, you might see a message like this instead:

Image Added

Image Added

This error appears because of special security settings found on the macOS platform, intended to prevent malware or other malicious code from being installed on the local hardware.

You will need to remove the quarantine attribute from the Adobe PDF Library SDK before you install the software, to make sure that you can run the sample programs without problems. 

Before you try to install the release package (.dmg file) that you downloaded from our FTP site, run this command:

xattr -d com.apple.quarantine ./APDFL18.0.3PlusP2f_MacOSX.dmg

In this example, you are working with the macOS release package for APDFL 18, "APDFL18.0.3PlusP2f_MaxOSX.dmg."

Now you may extract the contents of the .dmg file and the above error message will not appear when you try to run the sample programs.